Reply To: Branch Hours Setup

#34288
Althemist
Keymaster

Hello Digital Bird,

Sounds like you forgot to enable the checkbox “Override Global Order Hours Settings” in the branch settings.