ResolvedAlert display on Mobile

This topic contains 6 replies, has 2 voices, and was last updated by  khalil2099 5 months, 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #13621

    khalil2099
    Participant

    Hi,

    I noticed that the alert class is not displayed on mobile. Is there any quick CSS fix for it so that it will display on mobile browser ?

    this is the class:
    div woocommerce-notices-wrapper
    div woocommerce-message role=”alert”

    it is used to display message if a product is added to cart
    “Product Name” has been added to your cart. View cart

    Thanks.

    #13635

    Althemist
    Keymaster

    Hello khalil2099,

    We can’t just guess exactly what are you talking about and what could be wrong.

    Please provide more details and a link to your site, so we can check.

    #13637

    khalil2099
    Participant
    This reply has been marked as private.
    #13644

    Althemist
    Keymaster

    It’s not only for admin. This message is only shown IF the AJAX add to cart is disabled in WooCommerce options and in Theme Options for single product. Also, it’s enabled for grouped products and affiliate products. You’d need to check your woocommerce settings for this. It’s a core WooCommerce feature and not theme related.

    #13646

    khalil2099
    Participant

    i see.

    i tried turning off the ajax add to cart, still did not work. and there are not many options to change in the woocommerce settings page.

    not sure which part to modify the source code to enable it for normal products and public user.

    anyway, thanks.

    #13658

    Althemist
    Keymaster

    As we already explained, we can’t just guess!

    Provide a link to your site and temporary admin access details, so we can check.

    Regards,
    Dimitar

    #13685

    khalil2099
    Participant

    I figured it out already. Its not because of grouped products, affiliate products or woocommerce. Its because of where the notices are placed in the theme.

    When Im not logged in, the notices are shown above the login area. See here https://imgur.com/xKcxT7s .

    i fixed it by using javascript to move the “woocommerce-notices-wrapper” div to the place below the menu.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in and have valid license to reply to this topic.

License required for any item belonging to this account
AlThemist

AlThemist

sales 12277, followers 686
Login and Registration Log in · Register