ResolvedErrors with WooCommerce / Zass

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #14026
    llkbeasley
    Participant

    Getting several errors with the Zass theme. Please assist.

    Notice: wc_rest_controller was called incorrectly. Classes that extend the WooCommerce/WordPress REST API should only be loaded during the rest_api_init action, or should call WC()->api->rest_api_includes() manually. Backtrace: require_once(‘wp-admin/admin.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), do_action(‘init’), WP_Hook->do_action, WP_Hook->apply_filters, WCMp->init, WCMp->init_wcmp_rest_api, WCMp_REST_API->__construct, WCMp_REST_API->rest_api_init, WCMp_REST_API->rest_api_includes, WCMp_REST_API->load_controller_class, require_once(‘/plugins/dc-woocommerce-multi-vendor/api/class-wcmp-rest-vendors-controller.php’), spl_autoload_call, WC_Autoloader->autoload, wc_doing_it_wrong Please see Debugging in WordPress for more information. (This message was added in version 3.6.) in /home3/hellabla/public_html/api/wp-includes/functions.php on line 4667

    Warning: Cannot modify header information – headers already sent by (output started at /home3/hellabla/public_html/api/wp-includes/functions.php:4667) in /home3/hellabla/public_html/api/wp-admin/includes/misc.php on line 1198

    #14027
    llkbeasley
    Participant

    It’s saying these templates are out of date:

    zass/woocommerce/content-product.php version 3.4.0 is out of date. The core version is 3.6.0,

    zass/woocommerce/content-single-product.php version 3.4.0 is out of date. The core version is 3.6.0,

    zass/woocommerce/global/quantity-input.php version 3.4.0 is out of date. The core version is 3.6.0,

    zass/woocommerce/loop/orderby.php version 3.3.0 is out of date. The core version is 3.6.0,

    #14029
    llkbeasley
    Participant

    Wordpress is saying “Your theme (Zass) contains outdated copies of some WooCommerce template files. These files may need updating to ensure they are compatible with the current version of WooCommerce. Suggestions to fix this:

    Update your theme to the latest version. If no update is available contact your theme author asking about compatibility with the current WooCommerce version.
    If you copied over a template file to change something, then you will need to copy the new version of the template and apply your changes again. “

    #14077
    Alex
    Keymaster

    Hello llkbeasley,

    You need to update Zass theme with the latest version. And all plugins under Appearance -> Install plugins.
    Make sure you also update WC Marketplace plugin.

    For any further major and minor WooCommerce updates please first check if the theme was updated to be compatible to the new version. We always update the changelog on the theme page in Theme Forest.

    Regards,
    Alex

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in and have valid license to reply to this topic.

License required for any item belonging to this account
AlThemist

AlThemist

sales 13369, followers 699
Login and Registration Log in · Register