ResolvedProduct page short description cannot be saved

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #30901
    dora
    Participant

    Hello!

    I have big issues with not be bale to save data of product short description on some products.
    It is weird because some product pages allow to change and save the short description, some don’t.

    We already made the suggested tests like switching off the theme into 2019 or sth. and deactivate plugins though we only use plugins which are needed for woocommerce, there are no other plugins actually used except WP Security and Updraft plus.

    Could you please help what can be the problem here?

    Even if I duplicate a product which doesn’t allow to save short description and then try to save still doesnt’ work.
    By duplicating products which are editable and short description can be saved there is no problem to edit and save the short description field.

    Many thanks!
    D.

    #30903
    Althemist
    Keymaster

    Hi dora,

    If you give us a link to such product and temporary admin access, we can try to investigate it for you. Sounds like a JS error in your admin, but can’t tell for sure before I see it “live”.

    #30905
    dora
    Participant
    This reply has been marked as private.
    #30915
    dora
    Participant
    This reply has been marked as private.
    #30924
    Althemist
    Keymaster

    Hi dora,

    Username and password wouldn’t help without the website URL. Also, I am afraid we can’t invest the time to search your products by ID (assuming the numbers are ID’s which we don’t really know for sure by the message you left).

    Isn’t is easier to just give us a a working link to ONE product where the problem can be seen “live”? 🙂

    #30930
    dora
    Participant
    This reply has been marked as private.
    #30931
    dora
    Participant
    This reply has been marked as private.
    #30946
    Althemist
    Keymaster

    Hi Dora,

    Yes, we found the link. It’s a really strange problem. Could be related to your security plugin or server settings. The only thing I noticed is the fact you don’t have SSL installed on your domain, which is absolutely required for WooCommerce to work properly.

    Anyways, I suspect it’s most likely a cookies related problem caused by your security plugin, as this is what we see in the console when trying to save the product:

    Cookie “wp-saving-post” will be soon rejected because it has the “SameSite” attribute set to “None” or an invalid value, without the “secure” attribute. To know more about the “SameSite“ attribute, read https://developer.mozilla.org/docs/Web/HTTP/Headers/Set-Cookie/SameSite utils.min.js:2:893

    This page uses the non standard property “zoom”. Consider using calc() in the relevant property values, or using “transform” along with “transform-origin: 0 0”. post.php
    JQMIGRATE: Migrate is installed, version 3.3.2 jquery-migrate.min.js:2:709

    window.controllers/Controllers is deprecated. Do not use it for UA detection. ace.js:10:23901
    woocommerce_shared_settings filter in Blocks is deprecated. See https://github.com/woocommerce/woocommerce-gutenberg-products-block/blob/trunk/docs/contributors/block-assets.md post.php:9477:9

    MouseEvent.mozPressure is deprecated. Use PointerEvent.pressure instead. 2 wp-tinymce.js:3:8856

    Cookie “wp-saving-post” will be soon rejected because it has the “SameSite” attribute set to “None” or an invalid value, without the “secure” attribute. To know more about the “SameSite“ attribute, read https://developer.mozilla.org/docs/Web/HTTP/Headers/Set-Cookie/SameSite utils.min.js:2:893

    #30981
    dora
    Participant

    Dear,

    thank you for your answer.

    The problem is getting bigger. Now we see the same problem with the short description with more and more products.
    I made new products and same problem.

    I also deactivated the All In One WP Security & Firewall plugin as you said but nothing helps.

    Please suggest me some solutions because this is not doable anymore, we have to finish this job.

    Thank you so much.

    #30987
    Althemist
    Keymaster

    Hi dora,

    Unfortunately, there is nothing we can do, as it’s clearly not theme related. We have tested numerous times and it works absolutely fine on our end. As we already explained, it’s either a plugin conflict OR something wrong in the server configuration (check under WooCommerce > Status if there is something marked in red)

    #30988
    Althemist
    Keymaster

    Also, I can see you still don’t have SSL on that installation. As I already explained it’s absolutely required for the WooCommerce normal work.

    #30991
    dora
    Participant

    All right, thanks.

    we did not put ssl on the site yet because it is still in testing phase and it will be cloned to the actual site later. This is only a sub domain for making the site first.

    thank you for your help, though.

    Regards,
    D.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in and have valid license to reply to this topic.

License required for any item belonging to this account
AlThemist

AlThemist

sales 17221, followers 742
Login and Registration Log in · Register