ResolvedPtoblem with woo and with posts

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #20978
    BernieG2017
    Participant

    Hi – My host says this is an issue with the theme –

    Help please

    [29-Jan-2020 20:28:58 UTC] PHP Fatal error: Uncaught Error: Call to undefined function is_product() in /home/sewhapp2/public_html/wp-content/themes/babystreet/incl/woocommerce-functions.php:907

    #20997
    BernieG2017
    Participant

    Hi – Here is more information on the errors – I rolled back to Woocommerce 3.9 from 3.91 – and now there are all of these errors.

    The problem is you can’t read posts that are current.

    ###
    [29-Jan-2020 22:34:32 UTC] PHP Fatal error: Uncaught Error: Call to undefined function is_product() in /home/sewhapp2/public_html/wp-content/themes/babystreet/incl/woocommerce-functions.php:907
    Stack trace:
    #0 /home/sewhapp2/public_html/wp-content/themes/babystreet/incl/woocommerce-functions.php(869): babystreet_get_effective_gallery_type_setting()
    #1 /home/sewhapp2/public_html/wp-includes/class-wp-hook.php(288): babystreet_apply_effective_gallery_type_setting(Object(WP))
    #2 /home/sewhapp2/public_html/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters(”, Array)
    #3 /home/sewhapp2/public_html/wp-includes/plugin.php(544): WP_Hook->do_action(Array)
    #4 /home/sewhapp2/public_html/wp-includes/class-wp.php(742): do_action_ref_array(‘wp’, Array)
    #5 /home/sewhapp2/public_html/wp-includes/functions.php(1255): WP->main(”)
    #6 /home/sewhapp2/public_html/wp-blog-header.php(16): wp()
    #7 /home/sewhapp2/public_html/sapp-wp-signon.php(12): require(‘/home/sewhapp2/…’)
    #8 {main}
    thrown in /home/sewhapp2/public_html/wp-content/themes/babystreet/incl/woocommerce-functions.php on line 907
    ###

    #21001
    BernieG2017
    Participant

    Okay – Here is what is basically going on – I can’t get a straight answer from hosting company –

    But all my blog posts from 2019 are showing up. The ones from 2020 or that I edit in 2020 won’t open. I get errors in every browser that the page is basically lacking content. I can send screenshots but it’s like there is literally nothing there.

    You can check this link: https://sewhappyathome.com/blog/2020/01/30/testing-123/

    #21019
    Althemist
    Keymaster

    Hi BernieG2017,

    Sorry for the late reply.

    I am asking our lead developer Alex to step in and check the issue for you.

    He’ll be in touch as soon as possible.

    Regards,
    Dimitar

    #21027
    Alex
    Keymaster

    Hi BernieG2017,

    The errors that your are mentioning mean that something is wrong with the WooCommerce plugin. I mean something got broken. The plugin is registered as active, but it’s files are not reachable.

    Try to just copy the WooCommerce plugin files to the plugin path: wp-content/plugins/woocommerce/ . Double-check the correct path.

    Regards,
    Alex

    #21035
    BernieG2017
    Participant

    Hi –
     
    That did not work. 
    GreenGeeks thinks this is a theme issue – I have reinstalled the theme – but it still doesn’t work right. 

    Any other ideas – Basically – my blog is shut down. I can add new product – no issue and woocommerce works on checkout. It’s the blog that has a huge issue. No new posts can be seen and no old posts can be edited or they can’t be seen anymore either. 

    So basically- I have no blog

    #21036
    BernieG2017
    Participant

    Question – Should I have plugins from the babystreet theme in my MU plugin folder? I have none.

    #21058
    Alex
    Keymaster

    Hi,

    Please send us temporary admin login so we can check.

    You can use “Set as private reply” option.

    Regards,
    Alex

    #21059
    BernieG2017
    Participant
    This reply has been marked as private.
    #21060
    Alex
    Keymaster

    Thank you.
    We will look at it and let you know.

    Regards,
    Alex

    #21065
    Alex
    Keymaster

    Hi Bernie,

    I’ve looked at your site.
    Before going further try clearing all caches from the cache plugins.

    Your site has many active plugins and it is really difficult to say where exactly is the problem. In this case the best approach is to deactivate plugins one by one and examine when the symptom will disappear. Please do so and let us know.

    Also, We’ve noticed that you are using the child theme. Do you have any custom code in there? This could be the reason too.

    We understand that this can be frustrating, but this is the way to go in this case.

    Regards,
    Alex

    #21093
    BernieG2017
    Participant
    This reply has been marked as private.
    #21094
    BernieG2017
    Participant
    This reply has been marked as private.
    #21117
    Alex
    Keymaster
    This reply has been marked as private.
    #21138
    Alex
    Keymaster
    This reply has been marked as private.
Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in and have valid license to reply to this topic.

License required for any item belonging to this account
AlThemist

AlThemist

sales 13339, followers 699
Login and Registration Log in · Register