ResolvedShop page filter has disappeared

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #25403
    salescristofoli
    Participant

    Hi there,

    My shop filter has disappeared and I’m not sure why. I had set two attributes per product which covered a “colour” and “tag” but it is no longer showing.

    Any advice?

    #25457
    Alex
    Keymaster

    Hello salescristofoli,

    Sorry for the late answer.

    Please check if you have any “Refer Product Filter” widgets in the “Products Filters Sidebar”

    Regards,
    Alex

    #26269
    salescristofoli
    Participant

    Hi Alex,

    Apologies for my late response!

    Yes they are in. The filters were previously working fine, however, they have disappeared and I am unsure what change has caused the problem!

    #26294
    Althemist
    Keymaster

    Hi salescristofoli,

    Most probably you have updated your WordPress without updating the theme and all it’s plugins (including the Refer plugin). Just update everything to the latest version and than make sure you clear your site AND browser cache.

    Best reagrds,
    Dimitar

    #31266
    salescristofoli
    Participant

    Hi Dimitar,

    Apologies for the delayed response, still having this problem after clearing the cache. All plugins are up-to-date, and I have tried disabling each plugin to check for conflicts. Our site currently uses two separate product categories as shop fronts; however, the filter still does not show. Each product (combination of simple product and variable) has product attributes assigned, and I have configured the attributes in Woocommerce.

    If I visit the Woocommerce default store page, the filter is not there. If, however, I access the page in WordPress – Edit Page – Preview Changes (without making any changes), the preview page still shows no filters however shows “Reset all filters”. Pressing it removes the reset function and then proceeds to show no filters.

    As a side note, on both of these product categories, the filter attributes do not crossover. So if I displayed one product category, will it show all filter attributes or just the ones available for the product category selected?

    Regards,

    Alessandro

    #31280
    Althemist
    Keymaster

    Hi Alessandro,

    1. I am afraid we can’t just guess what could be wrong. Could you, please provide temporary admin access to your site, so we can check it “live”?

    2. Basically, WooCommerce only shows filters applicable to the current page (category). All filters are only available on the main shop page.

    #31288
    salescristofoli
    Participant
    This reply has been marked as private.
    #31301
    Althemist
    Keymaster

    The website URL would also help a lot! 🙂

    #31308
    salescristofoli
    Participant
    This reply has been marked as private.
    #31332
    Althemist
    Keymaster

    Found the problem. It looks like you are using an extremely old version of the theme with newer version of WordPress. You’d need to update the theme and theme plugin (Refer plugin” to the latest versions

    #31340
    salescristofoli
    Participant

    Thank you. I hadn’t linked the API key for Envato so didn’t see the theme required updating. Thank you for your help, apologies this was such a basic fix!

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in and have valid license to reply to this topic.

License required for any item belonging to this account
AlThemist

AlThemist

sales 17359, followers 742
Login and Registration Log in · Register