ResolvedSidebar does not show on Blog

Tagged: 

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #19507
    CraftingSonja
    Participant

    Hi there,

    I have some trouble with the default sidebar on the blog page: It shows up on the Blog page, but not on the blog-post-pages :(, except one or two blogposts.

    I tried a lot setups in the Theme setup and on the blogposts – I can’t find the bug :(.

    Can you help me?

    This is an example of a blogpost without sidebar (it shows up under the blogposts and comments): https://crafting-cafe.de/halloween-zauberermantel-naehen-tutorial/

    With this blogpost, the sidebar is there! But the setup is not different than the other one: https://crafting-cafe.de/neues-freebook-einschlagdecke-fur-babyschale-nahen/

    I’m really upset, I don’t get it. :/

    Thanks for your support, regards,
    Sonja

    #19527
    Althemist
    Keymaster

    Hi Sonja,

    The blog sidebar must be explicitly enabled for posts. If you’re using the demo content of the theme, the sidebar is explicitly disabled there for most of the post. You’d need to manually enable it for each post. When you edit the post, there will be a setting for this in the right-hand column.

    hope this helps.

    If you need more help, just let us know.

    Regards,
    Dimitar

    #19534
    CraftingSonja
    Participant

    Hi Dimitar,
    thank you!
    That means I have to enable the sidebar for every single post, right?
    Thank you, best regards,
    Sonja

    #19535
    CraftingSonja
    Participant

    Hello again,

    can you tell me where exactly I do the setup? It’s unter “Page structure options”, right?

    I compared the two blogposts but cannot find the difference…

    Thank you, best regards,
    Sonja

    #19570
    Althemist
    Keymaster

    Hi Main Sidebar,

    Sorry for the late reply.

    Yes, it is under “Page structure options”.

    Make sure it’s set to “Show” for the “Main sidebar” option.

    Also, make sure in Theme Options > Sidebars there is a sidebar set for the blog part of the website AND that in “Page structure options” the Main Sidebar is set to Default and not some other sidebar.

    If you still have difficulties, please provide temporary admin access, so we can check if everything is set correctly in your site.

    Regards,
    Dimitar

    #19753
    gquintana2014
    Participant
    This reply has been marked as private.
    #19788
    Althemist
    Keymaster

    Hello gquintana2014,

    Removed the code from your post as it breaks this page too.

    Could you, please provide temporary admin access, so we can check what could be wrong there?

    Regards,
    Dimitar

    #19796
    CraftingSonja
    Participant
    This reply has been marked as private.
    #19836
    Althemist
    Keymaster

    Hello Sonja,

    So sorry for the late reply. We were moving the office for the last few days. Sorry for the inconvenience.

    I have checked your site and it looks like you’re using the Gutenberg plugin. This is really not necessary as Gutenberg is part of the WooCommerce core since the last 4 or 5 versions. I’d suggest removing the Gutenberg plugin and also disable completely the Gutenberg editor completely in the WPBakery Page Builder settings, as it may conflict the theme features. Most probably that’s the reason for the wrong layout settings. Also, when you do this, you may need to manually re-save each post for the changes to take effect.

    Also, it looks like you are using a really old version of the theme as your blog layout is broken.

    Regards,
    Dimitar

    #19844
    CraftingSonja
    Participant

    Hi Dimitar,
    ok, thank you, I will try this – looks like tons of work :o.

    What do you mean with “blog layout is broken” and old version of the theme? It was updated last week, and I don’t see anything broken…?

    Thank you,
    Sonja

    #19851
    CraftingSonja
    Participant

    Hi Dimitar,

    I updated the Zass theme and I tried to deactivate Gutenberg, but then it will be deactivated on every post, right?
    I can’t do that – I love Gutenberg and I recently updated all my blogposts in that format – I won’t change that again!

    Is there any other possibility to get the sidebar where it belongs??

    I really love the Zass theme, I don’t want to change it again.

    Thank you,
    Sonja

    #19866
    Althemist
    Keymaster

    Hello Sonja,

    If you insist using the Gutenberg editor, just disable the gutenberg plugin and leave the original gutenberg which comes with the WordPress. However, the WPBakery page builder is much more flexible for building posts.

    Your blog page layout seems broken (just one post per row). I guess it’s not the real blog page, but page built with the blog posts shortcode which is now deprecated. Just set that page for blog page in Settings > Reading > Posts page.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in and have valid license to reply to this topic.

License required for any item belonging to this account
AlThemist

AlThemist

sales 13285, followers 699
Login and Registration Log in · Register