ResolvedUnable to upload image on vendor page and register page flow is confusing

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #18473
    craftii
    Participant

    1. Upload image for add product on vendor page is not working. Can refer to the links shown below to get the error.
    http://craftii-house.com/error/1_figure1.jpg
    http://craftii-house.com/error/1_figure2.jpg

    2. After login as vendor.
    When click on “Sell on Zass” (as shown in Figure 1), should shows the text something like “Go to vendor page” instead of showing “Vendor Registration Form” (As shown in Figure 2). This is so confusing as it will misleading user click on the text field and in fact they have already registered.
    Figure 1:
    http://craftii-house.com/error/2_figure1.jpg
    Figure 2:
    http://craftii-house.com/error/2_figure2.jpg

    #18513
    Althemist
    Keymaster

    Hello craftii,

    1. This sounds like a JS error on your site. If you provide URL to your site with temporary vendor account, we can try to investigate further.

    2. It sounds like your WooCommerce Account page and WCMp Dashboard and Registration page are not set properly. If everything is set as it should, the “Sell on Zass” link would automatically open the dashboard. This is not even theme related. It’s how the WCMp plugin works.

    Regards,
    Dimitar

    #18897
    craftii
    Participant

    Thanks for your reply.

    Here is temporary vendor account:
    URL: https://craftii-house.com/wcmp/
    Email: metok@mailnowapp.com
    Password: Hgty(%5!D9TQ

    1. Attachments are the issue we are facing.
    a. https://craftii-house.com/error/error_1a.jpg shows the HTTP error when we add the image under add product on vendor page
    b. https://craftii-house.com/error/error_1b.jpg is the error message we got
    c. Actually the images is uploaded, but only show out when we choose “Images” on drop down list. It doesn’t show up under “All media items” and the http error is still there. (https://craftii-house.com/error/error_1c.jpg)

    2. What I meant here is about user friendly issue, it’s so confusing right now. When I already registered/logged in as a vendor and it doesn’t show any message when I click on “Sell on Zass”. The page only shows “Vendor Registration Form” with dormant text field only. This is quite misleading. Just to feedback because I can see you have spent so much efforts and keep updating the template to make it perfect, I believe you’ll consider user’s feedback too. Thank you 🙂

    #18965
    Althemist
    Keymaster

    Hello craftii,

    Sorry for the delayed support. We have a severe ongoing medical emergency in family.

    1. I have just tested your site and I was able to upload a product image without any problems:

    Test Product

    Also, the error you’re getting is not theme related. There could be many reasons and they are mainly server related. Here is a good guide on how to diagnose and fix the problem if it still persists:

    https://www.hostinger.com/tutorials/http-error-when-uploading-images-to-wordpress

    2. Unfortunately, this is not theme related. It’s how WCMp plugin works. I know it’s not perfect, but there is not much we can do. May be you can use some sort of plugin showing differrent content to different user roles. There are many plugins like this available both free and premium.

    Regards,
    Dimitar

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in and have valid license to reply to this topic.

License required for any item belonging to this account
AlThemist

AlThemist

sales 13329, followers 699
Login and Registration Log in · Register