ResolvedWPML Language Selector: Issue when hovering in Zass

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #13354
    GilbertW
    Participant

    Dear Dimitar

    Yet another question… I made my site multilingual using WPML. I added a dropdown menu with country flags to change the language.

    There was an issue with the width of the field. I could partially solve this with the WPML Support. We added following CSS code in the Zass Child Theme:

    .zass-main-menu-right #main-menu > ul > li:nth-last-child(1) > ul.sub-menu, .zass-main-menu-right #main-menu > li:nth-last-child(2) > ul.sub-menu, .zass-main-menu-right.zass-stretched-header #main-menu > li:nth-last-child(3) > ul.sub-menu {
    left: auto;
    right: 0px;
    width: 100px;
    }

    Now the width of the menu is OK, but when we hover over it, their is still a problem as you can see under https://dev.swissbrew.ch. WPML Support can’t help further. They directed me to you.

    Could you please help with this issue? Thanks a lot!

    Regards, Gilbert

    #13360
    Althemist
    Keymaster

    Hello Gilbert,

    you can use the following CSS:

    #main-menu li ul.sub-menu li.wpml-ls-menu-item a {
    width: auto !important;
    }

    Also, we have a dedicated position for WPML language switcher in the theme, but the header top bar must be enabled.

    Regards,
    Dimitar

    #13364
    GilbertW
    Participant

    Hi Dimitar

    Another problem solved: You’re the man! Thanks a lot!

    Cheers,
    Gilbert

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in and have valid license to reply to this topic.

License required for any item belonging to this account
AlThemist

AlThemist

sales 14107, followers 704
Login and Registration Log in · Register